Contractor Talk - Professional Construction and Remodeling Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I don't know a whole bunch about this unit. It's 8 years old, is a heater/air conditioner. It's in a small double wide mobile home (rental unit). After the A/C has been running for about 7 or 8 hours it starts blowing warm air. Take the front of the A/C unit off and the interior unit is covered in ice. Does anyone know what would cause this??
 

·
Registered
Joined
·
227 Posts
Good chance (and most likely with the type of unit it is) your a-coil is dirty causing a restriction in airflow. Also could be a plugged filter or low on charge.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Think we got it figured out.

Had a fellow volunteer firefighter (A/C man) come and check out the unit for us. Every thing was clean and charged. Started looking into the wiring... looks like it might have been caused by the thermostat. Installed a new one yesterday evening and left it running all night (nobody living in the house right now). I haven't heard what the verdict is this morning. Sure hope this takes care of it though.
 

·
Registered
Joined
·
438 Posts
I do not think a thermostat is your problem if its freezing up, I would go back to the Doc ideas and check filters and coils also check to make sure the fan is running at its max speed and just be sure all of the registers are fully open.

Be sure the condensate drains are also working, and are clear of obstructions.

If alll of this proves to fail to solve the freeze, you need a charge

Bernie
 
1 - 4 of 4 Posts
Top