Contractor Talk - Professional Construction and Remodeling Forum banner

Ignition Switch Guard for Equipment

4612 Views 8 Replies 2 Participants Last post by  txgencon
I'm trying to find some sort of protective cover for the ignition switch for my Mustang MTL16 (same a Takeuchi TL130). Anyone have a source for such a thing?
1 - 9 of 9 Posts
I found this one.

http://www.safeandlockstore.com/die-cast-metal-cam-lock-dust-cover-spring-loaded-t107/



Why do you need one? I had a Takeuchi TL130, never worried about covering the switch.
I've ordered a replacment switch. I don't if someone messed with it or what. The "door" didn't close and it evidently got some crap down in it that keeps the key from going in far enough to operate. I tried vacuum, compressed air and WD40 with no luck. I never had trouble when I was using it in black dirt. But the sand where I use it now is a little more harsh environment (IMHO).
Why do you need one? I had a Takeuchi TL130, never worried about covering the switch.
Interesting. Here's the replacement switch. I didn't realize it was supposed to have a cover over the keyhole when not in use.

Attachments

A simple fix then. :D

I sold my TL130 a few years ago and don't recall if it had a switch cover or not. :rolleyes:
Now, for the switch replacement. IIRC, it will probably take longer to lift one terminal connection on the battery than it will take to R/R the switch.
The starter switch replacement went pretty smoothly and I got it going. About two uses back, the safety interlock (having to have the safety bar down for the controls to operate) ceased working. Turns out it uses a proximity switch to sense the position of the safety bar. The Gehl dealer I use for parts gave me a price for the little relay - $176.

I found the exact same switch (a new Idec DPRI-1) on eBay for $14.99 inclucing shipping. The only difference is that it doesn't have a quick connector in it.
I had a similar issue with the safety bar interlock.
Mine turned out to be the solenoid on the valve body was weak, sometimes the interlock worked, sometimes it did not. Took me a while to figure that one out.
I was lucky. It was the first thing I checked.The first thing I did was disconnect the relay (easy, since the connector was exposed behind the seat). That disabled the controls (as it should). Then took the relay off and checked for continuity. It was pretty obvious that it was stuck in the closed position (it's a normally open relay which closes when a little tab on the safety arm is positioned next to it). I tapped on it and passed metal next to it and it wouldn't open up. Due to the importance of its operation, I wouldn't have re-used it even it I could have gotten it to working.
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top