Contractor Talk - Professional Construction and Remodeling Forum banner

Hitachi CFS10

3274 6
My Hitachi 10" sliding mitre saw C10FS was just returned to me from a equipment vendor. When I turn it on, the blade doesn't spin. If I loosen the blade or remove it, the arbor spins fine.

Can you help?
1 - 7 of 7 Posts
something with the arbor washer....
what's an equipment vendor?

how olds the saw ?
Hitachi 10"

I have owned this Hitachi 10 inch sliding mitre saw for about 15 years. I recently brought it into a service shop or vendor for service. I asked them to align all settings and resquare.

I paid about $130 for this service. at the jobsite today, the blade would not turn. I took off the blade and the arbor spun freely. As I tightened the nut for the blade, the blade would not turn. I seems like the vendor - who are on vacation - returned the saw in a transport mode.

Please help.

Don
Transport mode? Never heard of that. No offense, but you wasted $130 on resquaring and truing it up?
  • Like
Reactions: m1911
There is no such thing as a Hitachi CFS10. It's a C10FS.

There is no such thing "transport mode."

Either one of the arbor washers is missing or installed backwards.

Who pays to square up a saw, it's part of knowing how to properly use your tools? :rolleyes:
I have owned this Hitachi 10 inch sliding mitre saw for about 15 years. I recently brought it into a service shop or vendor for service. I asked them to align all settings and resquare.

I paid about $130 for this service. at the jobsite today, the blade would not turn. I took off the blade and the arbor spun freely. As I tightened the nut for the blade, the blade would not turn. I seems like the vendor - who are on vacation - returned the saw in a transport mode.

Please help.

Don
Thanks for the info.:clap:
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top