Contractor Talk - Professional Construction and Remodeling Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I have a 2000 telsta a28d. boom will not move at all. tested controls from ground panel. getting 12.8 v in main control box in truck bed when ground control buttons are pushed. Also tested all of the solenoids. Getting 12.8v to each of the solenoids when buttons are pushed. The truck is a 2000 k3500 chevy that the telsta a28d is mounted on. Any ideas that could help me. I have no diagrams for this piece of equipment.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 · (Edited)
Thank you. I have looked at the tread. I could not get the diagrams. I went back out and tried the emergency over ride. Does not work either. also checked the hyd. pump on the onan gen. shaft is turning. I just got this truck 6 months ago. 4th time I've used it. Always rented.
 

·
Registered
Joined
·
131 Posts
Couple of things I have found that solved problems on mobile equipment, all after spending lots of time on other stuff - if it worked last time:1) A good ground is essential. Remove bolt or screw, wire brush, coat with NeverSeize, re-bolt, 2) Relay and fuse contacts corrode. Polish with emery paper, spray with CRC, push relay in and out several times. 3) Check for corrosion where wires are crimped to connectors. If corroded, cut off and crimp new connector. If someone worked on it before you, run.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
thanks charlie828. I've been working my butt off the last 2 days. I had looked at the connections this morning before i left. they are all corroded as much as I was able to see at 5:00 am. I will do as you suggest. thank you very much. Im at my wits end, not having the time nor the paper work for this equipment
 

·
Capra Aegagrus
Remodeler
Joined
·
25,297 Posts
Polish with emery paper, spray with CRC, push relay in and out several times.
Might get you running in a pinch, but will guarantee more trouble down the road. Relay contacts are plated, and sanding them removes the plating. They should be burnished instead.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 ·
Finally got a day off on monday. trouble shot all of the electrical on the bucket truck. found all elec. In good working order. since it is hydraulic over electric. we have a hyd problem. Something that is common to all boom controls. Called a bud of mine mr bruce who is a hyd guy. told him what was going on and sent him a pic of the hyd block. he told me that the main relief poppet valve was the issue. This is the only valve common to all controls. if the valve stuck opened would not built up press. to over come check valves. Got new main relief valve & installed all is working well. Thanks to all for the great advice and thank you mr bruce.
 
Joined
·
1 Posts
I have a 2000 telsta a28d. boom will not move at all. tested controls from ground panel. getting 12.8 v in main control box in truck bed when ground control buttons are pushed. Also tested all of the solenoids. Getting 12.8v to each of the solenoids when buttons are pushed. The truck is a 2000 k3500 chevy that the telsta a28d is mounted on. Any ideas that could help me. I have no diagrams for this piece of equipment.
Depress the parking brake to where the light comes on on the dash and should work then
 
1 - 9 of 9 Posts
Top