Contractor Talk - Professional Construction and Remodeling Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a three year old Goodman furnace, model PGB030075-1, that all of sudden will not ignite. The sequence that I am seeing after I flick the outside breaker, is the blower will start, the ignitor starts clicking and glowing red, but it seems that the gas it not being released.

The first time this happened I cleaned off all of the terminal connections with sand paper and it worked fine for about four days. The second time I cleaned up the terminal connection again thinking I had not done it thoroughly enough the first time. The furnace ran fine for about two days this time.

I noticed that any time I disconnect and reconnect the wires on an oval-shaped small silver metal looking part, that the system will start to work. This part has two male terminal connectors and two wires connect to it. It may be some kind of switch or capacitor, but I'm not sure. The white wire that connects to it goes down to the gas valve switch/solenoid.

It appears that the issue is the gas is not coming out to ignite. Any advice to what part I should replace?
 

·
NICKTECH
Joined
·
273 Posts
what you need to do is when the ignitor starts to get red check for voltage at the terminals on the gas valve. you should get 24 volts after the ignitor is at max temp. there will be a click in the furnace and then a click at the gas valve if you are reading 24v but there is no click there you might have a bad gas valve or loose connection. if there is a flame for about a second, then it is probably a dirty flame sensor which can be cleaned with steel wool. the small silver nickel shaped componant is a hi limit or roll out. its designed
to shut down the burner in case of a hi temp condition or in the event the burner should spit out flames. it is wired in series to the to the gas valve to shut it down directly. when you unit goes out again, before doing anything, check the to terminals of that switch with a voltmeter. if the switch is closed the reading will be 0. if the reading is 24v then the switch is open, if the switch is open then you may have an issue with the overheating or the ventor motor is not pulling right.or possibly the limit is bad. have a pro check it out :Thumbs:
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
It took one day for the furnace to out again. I checked the thermistor right after the furnace went out and it had 12VDC across it and showed an open when I check the resistance. I pressed the reset in the center and it showed a short. I guess when I was messing with the terminal connectors before, I was actually resetting the thermistor, and that's why it would start to work again.

I'm hoping it's just a faulty thermistor that's switching open too soon. Is there any way to test the thermistor to see if it's bad?

Would a bad vent motor cause overheating? Is there any way to test the vent motor?

I have a 5 year parts warranty through Goodman, so if I get a tech to come out will he be able to reimbursed directly through Goodman and not charge me for parts?

I do appreciate the assistance with this.
 

·
NICKTECH
Joined
·
273 Posts
absolutely, a bad vent motor may make the pressure switch and still not be pulling right, causing the burner to roll out or overheat. it may be a constant, or an intermittant problem. one of the ways to test the hi limit thermistor is to see what it is rated for and to take a temp reading around it. if it goes out prematurely then the limit is bad. when it comes to limts and system safetys, i would leave it to a pro! you should only be charged for labor. the burden of warranty reimbursement is left on the contractor. :Thumbs:
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
I agree with your suggestion and am having a tech come out today. I guess I could try to save a few bucks and get a new thermistor, but if there is something else faulty, I'm still going to need someone to come out and look at it.

Thanks for the help. I definitely learned some things about how my furnace works. The hardest part in the beginning was trying to figure which screws to remove to get off the panels. I eventually was able to get the small panel in the front off to get to the gas valve, and I only knew the whereabouts of the gas valve because I heard the ignitor clicking.

I've read on this forum that there can sometimes be issues with the pressure switches, and that water can build up in the tube that connects to the pressure switch. I was unable to find this tube. Do you know if my model has this?

I've also read that there are light indicators that will show what the fault is the system is. Do you know the location of these lights.

Thanks again.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
I got my questions answered by the HVAC tech who came out today. He showed me where the indicator lights are located, and it appears that the high limit switch is the issue. He also said the blower motor was too hot so he's going to replace both high limit switches and the blower motor.

He also told me that I don't have pressure switch on my unit.

Thanks again.
 
1 - 7 of 7 Posts
Top