Contractor Talk - Professional Construction and Remodeling Forum

Contractor Talk - Professional Construction and Remodeling Forum (https://www.contractortalk.com/forum.php)
-   HVAC (https://www.contractortalk.com/f6/)
-   -   Presure switch (https://www.contractortalk.com/f6/presure-switch-87289/)

C comfort 11-12-2010 10:07 PM

Presure switch
 
I am working on a Ducane Gas pack, and the pressure switch is not working. Replaced switch, unhooked the 2 wires and checked the switch while the ibm was running. The switch did not close for ignition. Cleaned the port at ibm and checked line for blockage. All checks out but the unit will not run unless the switch is jumped out. Could I have a bad exchanger that is causing a zero pressure difference.

cereal killer 11-13-2010 12:31 AM

Quote:

Originally Posted by C comfort (Post 1046276)
I am working on a Ducane Gas pack, and the pressure switch is not working. Replaced switch, unhooked the 2 wires and checked the switch while the ibm was running. The switch did not close for ignition. Cleaned the port at ibm and checked line for blockage. All checks out but the unit will not run unless the switch is jumped out. Could I have a bad exchanger that is causing a zero pressure difference.

Hey there C comfort. So you did your troubleshooting and came to the conclusion that the pressure switch was bad. How did you know it was bad?
You replaced the switch and it still doing the same thing. Did you check the flue? Have you looked at the hx? There is a possibility that it could be cracked.

beenthere 11-13-2010 05:22 AM

Could be bad heat exchanger.

Could be bad inducer, did you measure how much pressure the switch was sensing(a manometer helps for this)?

C comfort 11-13-2010 07:17 AM

The burners would light and go off within 10 seconds, so I replaced the flame sensor first but no luck. I could see the plunger on the switch move off the limit switch, but when it shut down the led light was flashing 3 times indicating a pressure swicth problem. Changed switch, checked hose, port, and still kicking out. No blockages were found, but I am going to check the hx today.

davidtrotsky 11-19-2010 07:28 PM

You need to look at the squirrel cage of the inducer motor. If it is rusted out or dirty it may not be moving the right amount of air to make the pressure switch.


All times are GMT -5. The time now is 05:13 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.