15 Yr Old Janitrol - HVAC - Contractor Talk

15 Yr Old Janitrol

 
Thread Tools Search this Thread Display Modes
Old 11-30-2013, 08:36 PM   #1
Registered User
 
tandree's Avatar
 
Trade: hvac
Join Date: Nov 2013
Location: grand rapids mi
Posts: 1
Rewards Points: 10

15 Yr Old Janitrol


I have installed old furnace in garage temped it first ran fine
While setting permanent tipped it and broke inducer motor
Installed new one now I'm getting rapid flashing or polarity is wrong
I ran wire myself so I know that's not the problem what would be the next step
To check ? The wires r correct on board even tryed swapping secondary wire just for giggles. Any ideas would help. Thanks
tandree is offline  

Warning: The topics covered on this site include activities in which there exists the potential for serious injury or death. ContractorTalk.com DOES NOT guarantee the accuracy or completeness of any information contained on this site. Always use proper safety precaution and reference reliable outside sources before attempting any construction or remodeling task!

   

Advertisement

 

Old 12-11-2013, 09:10 PM   #2
Member
 
Serviceplumber's Avatar
 
Trade: Plumber/gas fitter
Join Date: Nov 2013
Posts: 55
Rewards Points: 75

Re: 15 Yr Old Janitrol


Quote:
Originally Posted by tandree
I have installed old furnace in garage temped it first ran fine
While setting permanent tipped it and broke inducer motor
Installed new one now I'm getting rapid flashing or polarity is wrong
I ran wire myself so I know that's not the problem what would be the next step
To check ? The wires r correct on board even tryed swapping secondary wire just for giggles. Any ideas would help. Thanks
Huh? Would love to help but I'm not sure what you said? Lol


Has it got a hot surface igniter by chance ?.

Advertisement


Last edited by Serviceplumber; 12-11-2013 at 09:13 PM.
Serviceplumber is offline  
Old 12-11-2013, 10:55 PM   #3
HVAC Professional
 
HVAC1000's Avatar
 
Trade: Heating and Cooling
Join Date: Feb 2013
Location: Northern Colorado
Posts: 56
Rewards Points: 75

Re: 15 Yr Old Janitrol


Quote:
Originally Posted by tandree
I have installed old furnace in garage temped it first ran fine
While setting permanent tipped it and broke inducer motor
Installed new one now I'm getting rapid flashing or polarity is wrong
I ran wire myself so I know that's not the problem what would be the next step
To check ? The wires r correct on board even tryed swapping secondary wire just for giggles. Any ideas would help. Thanks
Did you make sure it has a good grounded connection too?
HVAC1000 is offline  


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Goodman / Trane Unregistered HVAC 54 07-09-2011 10:58 PM
Goodman Janitrol 075-3 wilson884 HVAC 4 10-23-2009 04:24 PM

Join Now... It's Fast and FREE!

I am a professional contractor
I am a DIY Homeowner
Drywall Talk is for
PROFESSIONAL CONTRACTORS ONLY!

At DrywallTalk.com we cater exlusivly to professional contractors who make their living as a contractor. Knowing that many homeowners and DIYers are looking for a community to call home, we've created www.DIYChatroom.com DIY Chatroom is full of helpful advices and perfect for DIY homeowners.

Redirecing in 10 seconds
No Thanks
terms of service

Already Have an Account?